Service兼容性

第一种:
Intent intent = new Intent(context,PushService.class);//PushService.getIntent();//
intent.setPackage(context.getPackageCodePath());
context.startService(intent);

第二种:
if (Build.VERSION.SDK_INT >= 26) { context.startForegroundService(PushService.getIntent());
} else { context.startService(PushService.getIntent());
}

哪种对android4.4-9.0 兼容性更好
2019-03-14 11:45 添加评论 分享
已邀请:

要回复问题请先登录注册

退出全屏模式 全屏模式 回复