急!升级到android sutdio 3.1.3,gradle4.4后,能运行,依赖却显示红线报错?

apply plugin: 'com.android.application'

android {
compileSdkVersion 27
//    buildToolsVersion "27.0.3"
defaultConfig {
    applicationId "com.ab.cd"
    minSdkVersion 21
    versionCode 10
    versionName "1.5.1"
    testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
}
buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
    }
}

flavorDimensions "TD_CHANNEL_VALUE"
productFlavors {
    kuan {
        manifestPlaceholders = [TD_CHANNEL_VALUE: "酷安"]
    }
    ali {
        manifestPlaceholders = [TD_CHANNEL_VALUE: "阿里"]
    }
}
applicationVariants.all { variant ->
    variant.outputs.all {
        outputFileName = "abc_${defaultConfig.versionCode}_${releaseTime()}_${variant.productFlavors[0].name}.apk"

    }
}

}


def releaseTime() {
return new Date().format("yyMMdd", TimeZone.getTimeZone("UTC"))
}


dependencies {
implementation fileTree(dir: 'libs', include: ['*.jar'])
//    androidTestImplementation('com.android.support.test.espresso:espresso-core:2.2.2', {
//        exclude group: 'com.android.support', module: 'support-annotations'
//    })
implementation files('libs/TalkingdataAnalytics.jar')
implementation files('libs/alipaySdk-20180316.jar')
implementation 'com.android.support:appcompat-v7:27.1.1'
implementation 'com.android.support:design:27.1.1'
implementation 'com.wang.avi:library:2.1.3'
implementation 'com.android.support.constraint:constraint-layout:1.0.2'
implementation 'com.loopj.android:android-async-http:1.4.9'
implementation 'de.hdodenhof:circleimageview:2.2.0'
implementation 'com.squareup.picasso:picasso:2.5.2'
implementation 'com.necer.ndialog2:ndialog:1.0.1'
implementation 'com.hanks:htextview-base:0.1.2'
implementation 'com.hanks:htextview-scale:0.1.2'
implementation 'com.andrognito.pinlockview:pinlockview:2.1.0'
implementation 'com.tencent.mm.opensdk:wechat-sdk-android-with-mta:5.1.4'
testImplementation 'junit:junit:4.12'
}


上图是我的配置文件。
运行到手机上是没问题的。
但是
但是
如附件所示,代码里,依赖的插件,都是报错的?
这是为什么?
3天了我也没解决掉。
2018-07-29 14:49 添加评论 分享
已邀请:

最佳回复

1

wodelinglong - hehe

赞同来自: ask

解决了。。
从AS里删了这个项目,重新import。
0

快乐小子 - 德玛西亚

赞同来自:

这个论坛都是自己解决自己展示的吗?

要回复问题请先登录注册

退出全屏模式 全屏模式 回复