创建一个Android project的时候就出现了Failed to resolve:junit:junit:4.12

2016-11-16 18:23 添加评论 分享
已邀请:

最佳回复

2

Silen - 民科

赞同来自: ask rustermChen

  1. 如果不需要单元测试,可以在build.gradle(Module:app)直接注释掉下面这行:
    testCompile 'junit:junit:4.12'
  2. 如果需要测试,则可以科学上网,你的AS一旦能够连接到万恶的资本主义网站后,这个问题就自动解决了。
  3. 作为2的备选方案也可以在build.gradle(Project:xxxx)中,修改jcenter()为显式的网址,比如国内的镜像网站,然后重新同步gradle。比如,可以把jcenter()替换为maven { url 'http://repo1.maven.org/maven2' }
0

焰火青春 - 努力不会错~

赞同来自:

我也和你同样的问题~
0

haigecnpeng - 80后

赞同来自:

度娘说直接注释掉它

要回复问题请先登录注册

退出全屏模式 全屏模式 回复