Android studio1.5编译出现-source 1.6 中不支持 switch的错误

在Android studio1.5上,编译工程,出现-source 1.6 中不支持 switch的错误,大家有知道怎么解决的吗?网上有人提供方法:将 Modules --->Sources ---> Language level 改为 7.0就ok了。但是在Android studio1.5以上都没有此选项了,将source compatibility 和 Target compatibility都改成1.7还是不行。

错误信息如下:
错误: -source 1.6 中不支持 switch 中存在字符串
switch (xxxx()){
^
(请使用 -source 7 或更高版本以允许 switch 中存在字符串)
2016-04-18 18:49 添加评论 分享
已邀请:

要回复问题请先登录注册

退出全屏模式 全屏模式 回复